Reverse Address Resolution ProtocolRARP (pour Reverse ARP) permet à partir d'une adresse matérielle (adresse MAC) de déterminer l'adresse IP d'une machine. En résumé, RARP (RFC 903) fait l'inverse de ARP (RFC 826). A ne pas confondre avec le protocole Inverse ARP (InARP) utilisé par les protocoles ATM ou Frame Relay, pour trouver aussi à partir d'une adresse de couche 2 du modèle OSI, une adresse de couche 3 du modèle OSI (RFC 2390). Le protocole RARP (Reverse Address Resolution Protocol) est beaucoup moins utilisé, il signifie Protocole ARP inversé, il s'agit donc d'une sorte d'annuaire inversé des adresses logiques et physiques.
Link-local addressIn computer networking, a link-local address is a unicast network address that is valid only for communications within the subnetwork that the host is connected to. Link-local addresses are most often assigned automatically with a process known as stateless address autoconfiguration or link-local address autoconfiguration, also known as automatic private IP addressing (APIPA) or auto-IP. Link-local addresses are not guaranteed to be unique beyond their network segment.
Linker (computing)In computing, a linker or link editor is a computer system program that takes one or more s (generated by a compiler or an assembler) and combines them into a single executable file, library file, or another "object" file. A simpler version that writes its output directly to memory is called the loader, though loading is typically considered a separate process. Computer programs typically are composed of several parts or modules; these parts/modules do not need to be contained within a single , and in such cases refer to each other by means of symbols as addresses into other modules, which are mapped into memory addresses when linked for execution.
Réalité virtuellevignette|250x250px|Personnel de l'U.S. Navy utilisant un simulateur de parachute. L'expression « réalité virtuelle » (ou multimédia immersif ou réalité simulée par ordinateur) renvoie typiquement à une technologie informatique qui simule la présence physique d'un utilisateur dans un environnement artificiellement généré par des logiciels. La réalité virtuelle crée un environnement avec lequel l'utilisateur peut interagir. La réalité virtuelle reproduit donc artificiellement une expérience sensorielle, qui peut inclure la vue, le toucher, l'ouïe et l'odorat (visuelle, sonore ou haptique).
Monde virtuelvignette|Un sous-marin jaune dans le monde virtuel de Second Life. Un monde virtuel est un monde créé artificiellement par un logiciel informatique et pouvant héberger une communauté d'utilisateurs présents sous forme d'avatars ayant la capacité de s'y déplacer et d'y interagir. La représentation de ce monde et de ses habitants est en deux ou en trois dimensions. Ce monde peut simuler le monde réel, avec ses lois physiques telles que la gravité, le temps, le climat, la géographie ou tout au contraire être régie par d'autres.
Virtual fixtureA virtual fixture is an overlay of augmented sensory information upon a user's perception of a real environment in order to improve human performance in both direct and remotely manipulated tasks. Developed in the early 1990s by Louis Rosenberg at the U.S. Air Force Research Laboratory (AFRL), Virtual Fixtures was a pioneering platform in virtual reality and augmented reality technologies. Virtual Fixtures was first developed by Louis Rosenberg in 1992 at the USAF Armstrong Labs, resulting in the first immersive augmented reality system ever built.
DNS dynamiqueUn DNS dynamique (Dynamic DNS, DDNS ou DynDNS) est une méthode pour mettre à jour automatiquement un serveur DNS, souvent en temps réel. Ces mots concernent deux concepts bien différents : au niveau de l'administration d'Internet, "dynamic DNS updating" concerne des systèmes qui sont utilisés pour mettre à jour les enregistrements DNS habituels sans édition manuelle. Ce principe est expliqué dans , et utilise le protocole TSIG (Transaction SIGnature) pour sécuriser ce mécanisme.
Dynamic Host Configuration Protocol(DHCP, protocole de configuration dynamique des hôtes) est un protocole réseau dont le rôle est d’assurer la configuration automatique des paramètres IP d’une station ou d'une machine, notamment en lui attribuant automatiquement une adresse IP et un masque de sous-réseau. DHCP peut aussi configurer l’adresse de la passerelle par défaut et configurer des serveurs de noms comme DNS ou NBNS (connu sous le nom de serveur WINS sur les réseaux de la société Microsoft).
C syntaxThe syntax of the C programming language is the set of rules governing writing of software in the C language. It is designed to allow for programs that are extremely terse, have a close relationship with the resulting object code, and yet provide relatively high-level data abstraction. C was the first widely successful high-level language for portable operating-system development. C syntax makes use of the maximal munch principle. C data types The C language represents numbers in three forms: integral, real and complex.
RentabilitéLa rentabilité est le rapport entre un revenu obtenu ou prévu et les ressources employées pour l'obtenir. La notion s'applique notamment aux entreprises, mais aussi à tout autre investissement. La rentabilité rétrospective est le rapport entre un résultat comptable et les moyens en passifs mis en œuvre pour l'obtenir. La rentabilité prévisionnelle est le rapport entre un gain de trésorerie projeté et la valeur d'un investissement nécessaire pour générer ce gain.
Types de donnée du langage CLes types de donnée du langage C définissent les caractéristiques de stockage et les opérations disponibles pour chaque valeur et chaque variable d'un code source en langage C. Les types fondamentaux du langage C sont conçus pour pouvoir correspondre aux types supportés par l'architecture de processeur cible. Le langage C possède une vingtaine de types fondamentaux pour représenter des nombres naturels, entiers et réels. Le langage offre une syntaxe pour construire des types d'adresse mémoire (pointeurs) vectoriels (tableaux) et composés (structures).
Retour sur investissementLe retour sur investissement (RSI ou rentabilité du capital investi), parfois appelé rendement, taux de rendement, taux de profit ou encore ROI (terme anglais, return on investment), désigne un ratio financier qui mesure le montant d'argent gagné ou perdu, par rapport à la somme initialement investie dans un investissement. Pour un investissement financier, ce ratio est généralement exprimé en pourcentage plutôt qu'en valeur décimale. Pour un investissement productif à durée de vie courte ou indéterminée (achat / développement de logiciels par exemple), ce sera l’inverse.