Suite des protocoles InternetLa suite des protocoles Internet est l'ensemble des protocoles utilisés pour le transfert des données sur Internet. Elle est aussi appelée suite TCP/IP, DoD Standard (DoD pour Department of Defense) ou bien DoD Model ou encore DoD TCP/IP ou US DoD Model. Elle est souvent appelée TCP/IP, d'après le nom de ses deux premiers protocoles : TCP (de l'anglais Transmission Control Protocol) et IP (de l'anglais Internet Protocol). Ils ont été inventés par Vinton G. Cerf et Bob Kahn, travaillant alors pour la DARPA, avec des influences des travaux de Louis Pouzin.
Qualité de serviceLa qualité de service (QDS) ou quality of service (QoS) est la capacité à véhiculer dans de bonnes conditions un type de trafic donné, en termes de disponibilité, débit, délais de transmission, gigue, taux de perte de paquets... La qualité de service est un concept de gestion qui a pour but d’optimiser les ressources d'un réseau (en management du système d'information) ou d'un processus (en logistique) et de garantir de bonnes performances aux applications critiques pour l'organisation.
Commutation de paquetsLa commutation de paquets, ou commutation par paquets, ou encore transmission par paquets, est une technique utilisée pour le transfert de données informatiques dans des réseaux spécialisés. Elle existe en deux grandes variantes : les datagrammes (données transmises sans connexions connues dans le réseau), et les circuits virtuels (données transmises avec connexions connues dans le réseau). La commutation par paquets est une méthode de regroupement de données qui sont transmises sur un réseau numérique sous forme de paquets composés d'un en-tête et d'une charge utile.
Resource Reservation ProtocolResource ReSerVation Protocol (ou RSVP) est un protocole de la couche transport du modèle OSI, permettant de réserver des ressources dans un réseau informatique. Les différents types de messages échangés sont : En provenance de l'émetteur : PATH PATHERR (erreur) PATHTEAR (abandon du flot) Du récepteur : RESV RESVERR RESVTEAR RFC 2205 Resource ReSerVation Protocol (RSVP) -- Version 1 Functional Specification RFC 2210 The Use of RSVP with IETF Integrated Services RFC 2211 Specification of the Controlled-Load
Orienté connexionDans les télécommunications, l'orienté connexion décrit un moyen de transmettre des données dans lequel : les appareils à chaque extrémité, utilisent un protocole préliminaire pour établir une connexion de bout en bout avant que les données soient envoyées ; les données sont envoyées le long d'un même chemin pendant la communication. Le service offert par un protocole orienté connexion est souvent, mais pas toujours, un service réseau « fiable », qui fournit la garantie que les données arriveront dans le bon ordre.
Integrated servicesEn informatique, le modèle IntServ (integrated services) définit une architecture capable de prendre en charge la Qualité de service (QoS) en définissant des mécanismes de contrôle complémentaires sans toucher au fonctionnement IP. C'est un modèle basé sur un protocole de signalisation RSVP. Au début, le protocole IP n'était pas prévu pour gérer la qualité de service QoS, du coup, les flux soumis à de fortes contraintes sur le plan de la qualité de service ont eu du mal à obtenir les « privilèges » nécessaires à leur bon acheminement sur le réseau Internet.
Differentiated servicesvignette|Differentiated services|301x301px DiffServ ou Differentiated Services est une architecture de réseau qui spécifie un mécanisme pour classer et contrôler le trafic tout en fournissant de la qualité de service (QoS), en différenciant les services des données. Tous les routeurs du domaine doivent être en DiffServ pour que cela puisse fonctionner. Leur gestion des priorités du trafic appelée (PHB), s'effectue alors selon les différents types de flux (VOIP, multimédia...).
Congestion (réseau)La congestion d'un réseau informatique est la condition dans laquelle une augmentation du trafic (flux) provoque un ralentissement global de celui-ci. Les trames entrantes dans les buffers des commutateurs sont rejetées dans ce cas. La congestion est liée à la politique du multiplexage établie sur le réseau considéré. La congestion peut être aussi liée aux équipements connectés sur le réseau, tels que switch, routeur, ordinateur... Donc pour résoudre ce problème le gestionnaire de réseau doit faire d'abord un troubleshoot pour identifier le problème.
Couche transportthumb|Position de la couche transport dans le modèle ISO et dans TCP-IP En réseaux, la couche dite de transport constitue la quatrième couche du modèle OSI. Cette couche regroupe l'ensemble des protocoles chargés de la gestion des erreurs et du contrôle des flux réseaux. Les deux principaux protocoles utilisés sont les protocoles TCP et UDP. Modèle OSI La couche transport gère les communications de bout en bout entre processus. Cette couche est souvent la plus haute couche où on se préoccupe de la correction des erreurs.
Principe de bout en boutLe principe de bout en bout (en anglais : end-to-end principle) est un principe central de l'architecture du réseau Internet. Il énonce que « plutôt que d’installer l’intelligence au cœur du réseau, il faut la situer aux extrémités : les ordinateurs au sein du réseau n’ont à exécuter que les fonctions très simples qui sont nécessaires pour les applications les plus diverses, alors que les fonctions qui sont requises par certaines applications spécifiques seulement doivent être exécutées en bordure de réseau.
Multilayer switchA multilayer switch (MLS) is a computer networking device that switches on OSI layer 2 like an ordinary network switch and provides extra functions on higher OSI layers. The MLS was invented by engineers at Digital Equipment Corporation. Switching technologies are crucial to network design, as they allow traffic to be sent only where it is needed in most cases, using fast, hardware-based methods. Switching uses different kinds of network switches. A standard switch is known as a layer 2 switch and is commonly found in nearly any LAN.
Transmission Control ProtocolTransmission Control Protocol (littéralement, « protocole de contrôle de transmissions »), abrégé TCP, est un protocole de transport fiable, en mode connecté, documenté dans la de l’IETF. Dans le modèle Internet, aussi appelé modèle TCP/IP, TCP est situé au-dessus de IP. Dans le modèle OSI, il correspond à la couche transport, intermédiaire de la couche réseau et de la couche session. Les applications transmettent des flux de données sur une connexion réseau.
Contrôle de fluxLe contrôle de flux, dans un réseau informatique ou un réseau de télécommunications, représente un asservissement du débit binaire de l'émetteur vers le récepteur. Quand une machine a un débit montant supérieur au débit descendant de la destination, la source diminue son débit pour ne pas submerger le puits de requêtes (obligeant parfois, lorsque le puits ne peut pas les traiter, à la ré-émission de ces dernières). Le contrôle de flux doit être différencié du contrôle de congestion, qui est utilisé pour contrôler le flux de données lorsque la congestion a déjà eu lieu.
Transmission en mode sans connexionDans un réseau à commutation de paquets, la transmission en mode non-connecté ou transmission en mode sans-connexion est une transmission de données dans laquelle chaque paquet est préfixé par un entête contenant une adresse de destination, suffisante pour permettre la livraison autonome du paquet, sans recours à d'autres instructions. Un paquet transmis en mode non-connecté est fréquemment appelé un datagramme. Dans une communication orientée connexion, les stations qui sont prêtes à échanger des données doivent d'abord se déclarer comme voulant effectivement le faire.
User Datagram ProtocolLe User Datagram Protocol (UDP, en français protocole de datagramme utilisateur) est un des principaux protocoles de télécommunication utilisés par Internet. Il fait partie de la couche transport du modèle OSI, quatrième couche de ce modèle, comme TCP. Il a été défini en 1980 par et est détaillé dans la . Le rôle de ce protocole est de permettre la transmission de données (sous forme de datagrammes) de manière très simple entre deux entités, chacune étant définie par une adresse IP et un numéro de port.
PPPoEPPPoE (de l'anglais point-to-point protocol over Ethernet) est un protocole d'encapsulation de PPP sur Ethernet, mis au point à l'origine par la société RedBack et décrit par le RFC 2516. PPPoE fut créé lors de l'arrivée de la liaison Ethernet pour remplacer le protocole PPP (Point to Point Protocol) qui permettait au fournisseur d’accès Internet, grâce à une authentification CHAP, d’identifier chacun de ses clients et voir s’ils étaient à jour de paiement.
LinuxLinux ou GNU/Linux est une famille de systèmes d'exploitation open source de type Unix fondés sur le noyau Linux créé en 1991 par Linus Torvalds. De nombreuses distributions Linux ont depuis vu le jour et constituent un important vecteur de popularisation du mouvement du logiciel libre. Si, à l'origine, Linux a été développé pour les ordinateurs compatibles PC, il n'a jamais équipé qu'une très faible part des ordinateurs personnels.
Packet forwardingPacket forwarding is the relaying of packets from one network segment to another by nodes in a computer network. The network layer in the OSI model is responsible for packet forwarding. The simplest forwarding modelunicastinginvolves a packet being relayed from link to link along a chain leading from the packet's source to its destination. However, other forwarding strategies are commonly used. Broadcasting requires a packet to be duplicated and copies sent on multiple links with the goal of delivering a copy to every device on the network.
Multiprotocol Label SwitchingDans les réseaux informatiques et les télécommunications, Multiprotocol Label Switching (MPLS) est un mécanisme de transport de données basé sur la commutation de labels (des « étiquettes »), qui sont insérés à l'entrée du réseau MPLS et retirés à sa sortie. À l'origine, cette insertion s'opère entre la couche de liaison de données (niveau 2) et la couche réseau (niveau 3) afin de transporter des protocoles comme IP. C'est pourquoi MPLS est qualifié de protocole de couche « 2,5 » ou « 2 / 3 ».
Fondation LinuxLa Fondation Linux (en anglais Linux Foundation) est un consortium à but non lucratif fondé le , il résulte de la fusion entre l'Open Source Development Labs et le . La Linux Foundation a pour mission de protéger et standardiser Linux en procurant les ressources et services centralisés nécessaires à concurrencer de manière efficace les autres systèmes d'exploitation. La Linux Foundation regroupe 70 membres parmi lesquels on trouve AMD, Fujitsu, HP, Hitachi, Intel, IBM, LG Group, Microsoft, NEC, Novell, Oracle, Orange, Samsung, Twitter, Valve, Yahoo! et d'autres.