Traffic shapingLe traffic shaping ou régulation de flux est le contrôle du volume des échanges dans un réseau informatique dans le but d’optimiser ou de garantir les performances, une latence plus faible ou d’augmenter la bande passante utilisable en retardant les paquets qui correspondent à certains critères. Plus particulièrement, le traffic shaping désigne toute action sur un groupe de paquets (un flux réseau) qui impose un délai supplémentaire à ces paquets pour qu’ils se conforment à une contrainte prédéterminée (contractuelle ou liée à un certain type de trafic).
Models of communicationModels of communication are simplified representations of the process of communication. Most models try to describe both verbal and non-verbal communication and often understand it as an exchange of messages. Their function is to give a compact overview of the complex process of communication. This helps researchers formulate hypotheses, apply communication-related concepts to real-world cases, and test predictions. Despite their usefulness, many models are criticized based on the claim that they are too simple because they leave out essential aspects.
Multicast addressA multicast address is a logical identifier for a group of hosts in a computer network that are available to process datagrams or frames intended to be multicast for a designated network service. Multicast addressing can be used in the link layer (layer 2 in the OSI model), such as Ethernet multicast, and at the internet layer (layer 3 for OSI) for Internet Protocol Version 4 (IPv4) or Version 6 (IPv6) multicast. IPv4 multicast addresses are defined by the most-significant bit pattern of 1110.
Théorie des typesEn mathématiques, logique et informatique, une théorie des types est une classe de systèmes formels, dont certains peuvent servir d'alternatives à la théorie des ensembles comme fondation des mathématiques. Ils ont été historiquement introduits pour résoudre le paradoxe d'un axiome de compréhension non restreint. En théorie des types, il existe des types de base et des constructeurs (comme celui des fonctions ou encore celui du produit cartésien) qui permettent de créer de nouveaux types à partir de types préexistant.
Type (informatique)vignette|Présentation des principaux types de données. En programmation informatique, un type de donnée, ou simplement un type, définit la nature des valeurs que peut prendre une donnée, ainsi que les opérateurs qui peuvent lui être appliqués. La plupart des langages de programmation de haut niveau offrent des types de base correspondant aux données qui peuvent être traitées directement — à savoir : sans conversion ou formatage préalable — par le processeur.
Communication organisationnelleLa communication organisationnelle est l'étude de la communication subordonnée à l'action organisée. C'est aussi l'ensemble des moyens de communication mis en œuvre pour la réalisation d'une tâche organisée. Dans le domaine de la recherche, aux États-Unis ce champ de recherche relève tout naturellement des communication studies, en France la communication organisationnelle est un domaine qui peut être revendiqué par des chercheurs des Sciences de l'Information et de la Communication, mais aussi en Sociologie des organisations, ou encore en sciences de gestion.
Cut throughCut-Through ou traitement "à la volée" est une technique en informatique qui permet d'améliorer la vitesse de transmission d'une trame de données dans un équipement comme un commutateur réseau ou un pare-feu. Le traitement conventionnel en mode différé consiste à attendre la réception complète d'une trame et son analyse éventuelle avant de la relayer vers un autre équipement du réseau. Le traitement à la volée consiste à envoyer une trame en sortie dès le début de sa réception en entrée, ou sans attendre de l'avoir totalement reçue.
Théorie des réseauxvignette|Graphe partiel de l'internet, basé sur les données de opte.org du 15 janvier 2005 (voir description de l'image pour plus de détails) La théorie des réseaux est l'étude de graphes en tant que représentation d'une relation symétrique ou asymétrique entre des objets discrets. Elle s'inscrit dans la théorie des graphes : un réseau peut alors être défini comme étant un graphe où les nœuds (sommets) ou les arêtes (ou « arcs », lorsque le graphe est orienté) ont des attributs, comme une étiquette (tag).
Resource Reservation ProtocolResource ReSerVation Protocol (ou RSVP) est un protocole de la couche transport du modèle OSI, permettant de réserver des ressources dans un réseau informatique. Les différents types de messages échangés sont : En provenance de l'émetteur : PATH PATHERR (erreur) PATHTEAR (abandon du flot) Du récepteur : RESV RESVERR RESVTEAR RFC 2205 Resource ReSerVation Protocol (RSVP) -- Version 1 Functional Specification RFC 2210 The Use of RSVP with IETF Integrated Services RFC 2211 Specification of the Controlled-Load
Multiprotocol Label SwitchingDans les réseaux informatiques et les télécommunications, Multiprotocol Label Switching (MPLS) est un mécanisme de transport de données basé sur la commutation de labels (des « étiquettes »), qui sont insérés à l'entrée du réseau MPLS et retirés à sa sortie. À l'origine, cette insertion s'opère entre la couche de liaison de données (niveau 2) et la couche réseau (niveau 3) afin de transporter des protocoles comme IP. C'est pourquoi MPLS est qualifié de protocole de couche « 2,5 » ou « 2 / 3 ».
Réseau superposéthumb|Un réseau superposé et ses couches successives. Un réseau superposé, ou réseau overlay, est un réseau informatique bâti sur un autre réseau. Les nœuds du réseau superposé sont interconnectés par des liens logiques du réseau sous-jacent. La complexité du réseau sous-jacent n'est pas visible par le réseau superposé. Cette abstraction du réseau sous-jacent est une source d'inefficacité des flux, qui peuvent transiter plusieurs fois par les mêmes liens physiques.
Conversion de typeEn informatique la conversion de type, le transtypage ou la coercition (cast en anglais) est le fait de convertir une valeur d'un type (source) dans un autre (cible). On distingue trois formes de conversion (dont un seul mérite vraiment le nom de conversion) suivant la relation de sous-typage existant entre les types source et cible : la conversion entre types incomparables ; la coercition ascendante (transtypage vers le haut) ; la coercition descendante (transtypage vers le bas). C'est la coercition la plus ancienne historiquement.