Histoire d'InternetLhistoire d'Internet remonte au début des années 1960. L'idée d’un réseau informatique, permettant aux utilisateurs de différents ordinateurs de communiquer, se développa par de nombreuses étapes successives. La somme de tous ces développements conduisit au « réseau des réseaux » (network of networks) que nous connaissons aujourd’hui en tant qu'Internet. Il est le fruit à la fois de développements technologiques et du regroupement d’infrastructures réseau existantes et de systèmes de télécommunications.
Squid (logiciel)Un serveur Squid est un serveur mandataire (proxy) et un mandataire inverse conçu pour relayer les protocoles , HTTP, Gopher, et HTTPS. Contrairement aux serveurs proxy classiques, un serveur Squid gère toutes les requêtes en un seul processus d'entrée/sortie asynchrone. C'est un logiciel libre distribué sous licence GNU GPL. Squid garde les meta-données et plus particulièrement les données les plus fréquemment utilisées en mémoire. Il conserve aussi en mémoire les requêtes DNS, ainsi que les requêtes ayant échoué.
Rewrite engineIn web applications, a rewrite engine is a software component that performs rewriting on URLs (Uniform Resource Locators), modifying their appearance. This modification is called URL rewriting. It is a way of implementing URL mapping or routing within a web application. The engine is typically a component of a web server or web application framework. Rewritten URLs (sometimes known as short, pretty or fancy URLs, search engine friendly - SEF URLs, or slugs) are used to provide shorter and more relevant-looking links to web pages.
ChromiumChromium est un navigateur web libre développé par l’organisation Chromium Project créée par Google en 2008. Chromium sert de base à plusieurs autres navigateurs, dont certains open-source (Brave, Iridium...) ou certains propriétaires (Vivaldi Browser, Google Chrome, SRWare Iron, Yandex Browser, Opera & Opera GX, Microsoft Edge). Le moteur de rendu de Chromium s'appelle Blink. Google a remplacé le moteur de rendu WebKit par Blink depuis . Il permettrait de rendre le navigateur plus stable et plus léger.
Conception de site webLa création et la conception de site web ou web design est la conception de l'interface web : l’architecture interactionnelle, l’organisation des pages, l’arborescence et la navigation dans un site web. La conception d'un design web tient compte des contraintes spécifiques du support Internet, notamment en matière d’ergonomie, d’utilisabilité et d’accessibilité. Le web design réclame donc des compétences en programmation, en ergonomie et en interactivité, ainsi qu'une bonne connaissance des contraintes techniques liées à ce domaine.
Uniform Resource IdentifierUn URI, de l'anglais Uniform Resource Identifier, soit littéralement identifiant uniforme de ressource, est une courte chaîne de caractères identifiant une ressource sur un réseau (par exemple une ressource Web) physique ou abstraite, et dont la syntaxe respecte une norme d'Internet mise en place pour le World Wide Web (voir RFC 3986). La norme était précédemment connue sous le terme UDI. L'IETF l'a d'abord défini dans la RFC 2396 en se basant sur des propositions de Tim Berners-Lee (RFC 1630).
Algorithme de triUn algorithme de tri est, en informatique ou en mathématiques, un algorithme qui permet d'organiser une collection d'objets selon une relation d'ordre déterminée. Les objets à trier sont des éléments d'un ensemble muni d'un ordre total. Il est par exemple fréquent de trier des entiers selon la relation d'ordre usuelle « est inférieur ou égal à ». Les algorithmes de tri sont utilisés dans de très nombreuses situations. Ils sont en particulier utiles à de nombreux algorithmes plus complexes dont certains algorithmes de recherche, comme la recherche dichotomique.
Analyse sémantique latenteL’analyse sémantique latente (LSA, de l'anglais : Latent semantic analysis) ou indexation sémantique latente (ou LSI, de l'anglais : Latent semantic indexation) est un procédé de traitement des langues naturelles, dans le cadre de la sémantique vectorielle. La LSA fut brevetée en 1988 et publiée en 1990. Elle permet d'établir des relations entre un ensemble de documents et les termes qu'ils contiennent, en construisant des « concepts » liés aux documents et aux termes.
Internet ArchiveInternet Archive (ou IA) est un organisme à but non lucratif consacré à l’archivage du Web qui agit aussi comme bibliothèque numérique. Ces archives électroniques sont constituées de clichés instantanés (copie de pages prises à différents moments) de pages web, de logiciels, de films, de livres et d’enregistrements audio. Pour assurer la stabilité et la sécurité des données archivées, un site miroir fonctionnel est conservé à la Bibliotheca Alexandrina en Égypte.
Internet par satellitealt=Antenne internet satellite portable|vignette|Antenne internet satellite portable Internet par satellite est à la fois une méthode d'accès au réseau Internet et un mode de large diffusion via une transmission satellitaire à destination du grand public ou des entreprises. Le foyer ou le véhicule est équipé d'une antenne de réception satellite (exemple : antenne parabolique) disposant à la fois d'un dispositif de réception (liaison descendante) et d'un système d'émission intégré (liaison montante).
Révélations d'Edward Snowdenvignette|droite|upright=1|Edward Snowden en 2013. Les révélations d'Edward Snowden commencent avec un important volume de documents () transmis par l'ancien agent de la CIA et consultant de la NSA Edward Snowden à deux journalistes, Glenn Greenwald et Laura Poitras, et progressivement rendus publics à partir du à travers plusieurs titres de presse. Elles concernent la surveillance d'internet, des téléphones portables et de tous les moyens de télécommunication mondiaux par la NSA.
Internet manipulationInternet manipulation refers to the co-optation of digital technology, such as social media algorithms and automated scripts, for commercial, social, or political purposes. Such tactics may be employed with the explicit intent to manipulate public opinion, polarise citizens, silence political dissidents, harm corporate or political adversaries and improve personal or brand reputation. Hackers, hired professionals and private citizens have all been reported to engage in internet manipulation using software - typically Internet bots such as social bots, votebots and clickbots.