Measuring network throughputThroughput of a network can be measured using various tools available on different platforms. This page explains the theory behind what these tools set out to measure and the issues regarding these measurements. Reasons for measuring throughput in networks. People are often concerned about measuring the maximum data throughput in bits per second of a communications link or network access. A typical method of performing a measurement is to transfer a 'large' file from one system to another system and measure the time required to complete the transfer or copy of the file.
Channel access methodIn telecommunications and computer networks, a channel access method or multiple access method allows more than two terminals connected to the same transmission medium to transmit over it and to share its capacity. Examples of shared physical media are wireless networks, bus networks, ring networks and point-to-point links operating in half-duplex mode. A channel access method is based on multiplexing, that allows several data streams or signals to share the same communication channel or transmission medium.
Suite des protocoles InternetLa suite des protocoles Internet est l'ensemble des protocoles utilisés pour le transfert des données sur Internet. Elle est aussi appelée suite TCP/IP, DoD Standard (DoD pour Department of Defense) ou bien DoD Model ou encore DoD TCP/IP ou US DoD Model. Elle est souvent appelée TCP/IP, d'après le nom de ses deux premiers protocoles : TCP (de l'anglais Transmission Control Protocol) et IP (de l'anglais Internet Protocol). Ils ont été inventés par Vinton G. Cerf et Bob Kahn, travaillant alors pour la DARPA, avec des influences des travaux de Louis Pouzin.
Wireless USBLe Wireless USB ou WUSB est une norme informatique de technique radio courte distance destinée à simplifier les connexions entre les appareils électroniques. Elle visait à compléter et à remplacer la norme USB par câble. Cependant, les industriels abandonnent les uns après les autres le projet, pour se consacrer à l’. Le WUSB étend la portée maximale des échanges à contre en USB, avec toutefois des débits théoriques offerts décroissant en fonction de la distance : de () dans un rayon de , ils chutent à () dans un rayon de .
Taux d'erreurLe taux d'erreur ou B.E.R., abréviation de l'expression anglaise Bit Error Rate, désigne une valeur, relative au taux d'erreur, mesurée à la réception d'une transmission numérique, relative au niveau d'atténuation et/ou de perturbation d'un signal transmis. Ce phénomène survient également lors de l'échantillonnage (numérisation), lors de la lecture et de la sauvegarde des données (CD-R, DVD-R, disque dur, RAM...). Ce taux détermine le nombre d'erreurs apparues entre la modulation et juste après la démodulation du signal.
Congestion (réseau)La congestion d'un réseau informatique est la condition dans laquelle une augmentation du trafic (flux) provoque un ralentissement global de celui-ci. Les trames entrantes dans les buffers des commutateurs sont rejetées dans ce cas. La congestion est liée à la politique du multiplexage établie sur le réseau considéré. La congestion peut être aussi liée aux équipements connectés sur le réseau, tels que switch, routeur, ordinateur... Donc pour résoudre ce problème le gestionnaire de réseau doit faire d'abord un troubleshoot pour identifier le problème.
Capacité d'un canalLa capacité d'un canal, en génie électrique, en informatique et en théorie de l'information, est la limite supérieure étroite du débit auquel l'information peut être transmise de manière fiable sur un canal de communication. Suivant les termes du théorème de codage du canal bruyant, la capacité d'un canal donné est le débit d'information le plus élevé (en unités d'information par unité de temps) qui peut être atteint avec une probabilité d'erreur arbitrairement faible. La théorie de l'information, développée par Claude E.
Réseaux sans fil communautairesLes réseaux sans fil communautaires ou projets sans fil communautaires désignent des réseaux informatiques sans fil et les communautés qui les développent, principalement constituées par des passionnés. Ils consistent en des réseaux informatiques utilisant des technologies de type réseau local sans fil, profitant du récent développement de technologies standard à faible coût (comme le standard 802.11b appartenant au groupe de normes IEEE 802.
Reverse Address Resolution ProtocolRARP (pour Reverse ARP) permet à partir d'une adresse matérielle (adresse MAC) de déterminer l'adresse IP d'une machine. En résumé, RARP (RFC 903) fait l'inverse de ARP (RFC 826). A ne pas confondre avec le protocole Inverse ARP (InARP) utilisé par les protocoles ATM ou Frame Relay, pour trouver aussi à partir d'une adresse de couche 2 du modèle OSI, une adresse de couche 3 du modèle OSI (RFC 2390). Le protocole RARP (Reverse Address Resolution Protocol) est beaucoup moins utilisé, il signifie Protocole ARP inversé, il s'agit donc d'une sorte d'annuaire inversé des adresses logiques et physiques.
Réseau informatiquethumb|upright|Connecteurs RJ-45 servant à la connexion des réseaux informatiques via Ethernet. thumb|upright Un réseau informatique ( ou DCN) est un ensemble d'équipements reliés entre eux pour échanger des informations. Par analogie avec un (un réseau est un « petit rets », c'est-à-dire un petit filet), on appelle nœud l'extrémité d'une connexion, qui peut être une intersection de plusieurs connexions ou équipements (un ordinateur, un routeur, un concentrateur, un commutateur).
Agrégation de liens333px|right|thumb|Une application de l'agrégation de liens. L'agrégation de liens est une technique utilisée dans les réseaux informatiques, permettant le regroupement de plusieurs ports réseau et de les utiliser comme s'il s'agissait d'un seul. Le but est d’accroitre le débit au-delà des limites d'un seul lien, et éventuellement de faire en sorte que les autres ports prennent le relai si un lien tombe en panne (redondance).
Turbo codeTurbo code est le nom générique d'un code correcteur imaginé dans les années 1990, qui permet de s'approcher aussi près qu'on le souhaite de la limite de Shannon. Les turbo codes représentent une percée majeure dans le domaine des communications numériques. Ils sont utilisés dans de nombreux standards de téléphonie mobile (UMTS, LTE), de communications par satellites (Inmarsat, DVB-RCS) ou de courants porteurs en ligne. Leur inventeur est Claude Berrou qui breveta cette technologie pour le compte de France Télécom et TDF.