Protocole de communicationDans les réseaux informatiques et les télécommunications, un protocole de communication est une spécification de plusieurs règles pour un type de communication particulier. Initialement, on nommait protocole ce qui est utilisé pour communiquer sur une même couche d'abstraction entre deux machines différentes. Par extension de langage, on utilise parfois ce mot aussi aujourd'hui pour désigner les règles de communication entre deux couches sur une même machine.
Contrôle d'accès au supportLa sous-couche de contrôle d'accès au support (abrégée MAC, de l’anglais Media Access Control) est la moitié basse de la couche de liaison de données du modèle OSI, selon les standards de réseaux informatiques IEEE 802.x. Elle sert d'interface entre la partie logicielle contrôlant la liaison d'un nœud (Contrôle de la liaison logique) et la couche physique (matérielle). Par conséquent, elle est différente selon le type de média physique utilisé (Ethernet, Token Ring, WLAN, ...
Couche physiquevignette|Exemple d'interconnexions en niveau de couche physique Dans le domaine des réseaux informatiques, la couche physique est la première couche du modèle OSI (de l'anglais Open Systems Interconnection, « Interconnexion de systèmes ouverts »). La couche physique est chargée de la transmission effective des signaux électriques, radiofréquences ou optiques entre les interlocuteurs. Son service est généralement limité à l'émission et la réception d'un bit ou d'un train de bits continu (notamment pour les supports synchrones comme la fibre optique).
Couche liaison de donnéesvignette|Modèle OSI complet avec la couche liaison en deuxième position en partant du bas Dans le domaine des réseaux informatiques, la couche de liaison de données est la seconde couche des sept couches du modèle OSI. La couche de liaison de données est la couche de protocole qui transfère des données entre les nœuds adjacents d'un réseau étendu (WAN) ou entre des nœuds sur le même segment d'un réseau local (LAN).
Address Resolution ProtocolL’Address Resolution Protocol (ARP, protocole de résolution d’adresse) est un protocole utilisé pour associer l'adresse de protocole de couche réseau (typiquement une adresse IPv4) d'un hôte distant, à son adresse de protocole de couche de liaison (typiquement une adresse MAC). Il se situe à l’interface entre la couche réseau ( du modèle OSI) et la couche de liaison ( du modèle OSI). Il a été défini en 1982 dans la Request for comments : An Ethernet Address Resolution Protocol.
Adresse MACUne adresse MAC (de l'anglais Media Access Control), parfois nommée adresse physique, est un identifiant physique stocké dans une carte réseau ou une interface réseau similaire. Elle est unique au monde. Toutes les cartes réseau ont une adresse MAC, même celles contenues dans les PC et autres appareils connectés (tablette tactile, smartphone, consoles de jeux, réfrigérateurs, montres). MAC constitue la partie inférieure de la couche de liaison (couche 2 du modèle OSI). Elle insère et traite ces adresses au sein des trames transmises.
Pile de protocolesUne pile de protocoles est une mise en œuvre particulière d'un ensemble de protocoles de communication réseau. L'intitulé « pile » implique que chaque couche de protocole s'appuie sur celles qui sont en dessous afin d'y apporter un supplément de fonctionnalité. Il en existe de plusieurs : thumb|Position de la couche réseau dans le modèle OSI et dans TCP-IP • Le « modèle de référence OSI » — OSI signifiant « Open Systems Interconnection » soit en français « Interconnexion de systèmes ouverts » — défini par l'ISO décrit ainsi sept couches empilées les unes sur les autres.
Link layerIn computer networking, the link layer is the lowest layer in the Internet protocol suite, the networking architecture of the Internet. The link layer is the group of methods and communications protocols confined to the link that a host is physically connected to. The link is the physical and logical network component used to interconnect hosts or nodes in the network and a link protocol is a suite of methods and standards that operate only between adjacent network nodes of a network segment.
Reverse Address Resolution ProtocolRARP (pour Reverse ARP) permet à partir d'une adresse matérielle (adresse MAC) de déterminer l'adresse IP d'une machine. En résumé, RARP (RFC 903) fait l'inverse de ARP (RFC 826). A ne pas confondre avec le protocole Inverse ARP (InARP) utilisé par les protocoles ATM ou Frame Relay, pour trouver aussi à partir d'une adresse de couche 2 du modèle OSI, une adresse de couche 3 du modèle OSI (RFC 2390). Le protocole RARP (Reverse Address Resolution Protocol) est beaucoup moins utilisé, il signifie Protocole ARP inversé, il s'agit donc d'une sorte d'annuaire inversé des adresses logiques et physiques.
Tunnel (réseau informatique)Un tunnel, dans le contexte des réseaux informatiques, est une encapsulation de données d'un protocole réseau dans un autre, situé dans la même couche du modèle en couches, ou dans une couche de niveau supérieur. D'abord, le paquet est enveloppé dans un en-tête supplémentaire (additional header), c'est ce qu'on appelle l'encapsulation. Cet en-tête supplémentaire contient les informations de routage nécessaires pour envoyer le paquet encapsulé à travers l'inter-réseau intermédiaire.
Protocole cryptographiqueUn protocole de sécurité (protocole cryptographique ou protocole de chiffrement) est un protocole abstrait ou concret qui remplit une fonction liée à la sécurité et applique des méthodes cryptographiques, souvent sous forme de séquences de primitives cryptographiques. Un protocole décrit comment les algorithmes doivent être utilisés et inclut des détails sur les structures de données et les représentations, à quel point il peut être utilisé pour implémenter plusieurs versions interopérables d'un programme.
Suite des protocoles InternetLa suite des protocoles Internet est l'ensemble des protocoles utilisés pour le transfert des données sur Internet. Elle est aussi appelée suite TCP/IP, DoD Standard (DoD pour Department of Defense) ou bien DoD Model ou encore DoD TCP/IP ou US DoD Model. Elle est souvent appelée TCP/IP, d'après le nom de ses deux premiers protocoles : TCP (de l'anglais Transmission Control Protocol) et IP (de l'anglais Internet Protocol). Ils ont été inventés par Vinton G. Cerf et Bob Kahn, travaillant alors pour la DARPA, avec des influences des travaux de Louis Pouzin.
Ethernet physical layerThe physical-layer specifications of the Ethernet family of computer network standards are published by the Institute of Electrical and Electronics Engineers (IEEE), which defines the electrical or optical properties and the transfer speed of the physical connection between a device and the network or between network devices. It is complemented by the MAC layer and the logical link layer. The Ethernet physical layer has evolved over its existence starting in 1980 and encompasses multiple physical media interfaces and several orders of magnitude of speed from 1 Mbit/s to 400 Gbit/s.
Canal sodiumUn canal sodium, ou sodique, est un canal ionique spécifique aux ions sodium. Il en existe de plusieurs types. Le premier à avoir été décrit est le canal sodique du potentiel d'action, responsable entre autres de la dépolarisation du neurone et du myocyte, de la propagation du signal nerveux et de la propagation de l'activation électrique du myocarde. thumb|Vue schématique du canal sodique La sous-unité Alpha constituée de quatre domaines et formant le pore central du canal ainsi que ses deux sous-unités béta Il faut différencier les canaux sodium stricts des canaux perméants aux cations, c’est-à-dire principalement sodium et potassium.
Point-to-Point ProtocolPoint-to-Point Protocol (PPP, protocole point à point) est un protocole de transmission pour internet, décrit par le standard RFC 1661, fortement basé sur HDLC, qui permet d'établir une connexion entre deux hôtes sur une liaison point à point. Il fait partie de la couche liaison de données (couche 2) du modèle OSI. PPP s'appuie sur trois composants : L'encapsulation des datagrammes. Le contrôle de la liaison avec LCP (Link Control Protocol). Le contrôle de la couche réseau avec NCP (Network Control Protocol).
Protocol Data UnitLa Protocol Data Unit ou Unité de données de protocole (PDU) est l'unité de mesure des informations échangées dans un réseau informatique. Appliqué au système de couches du modèle OSI, le PDU : de la couche physique est le bit ; de la couche liaison est la trame ; de la couche réseau est le paquet ; de la couche transport est le segment pour TCP, et le datagramme pour UDP ; des couches application, présentation et session sont les données. Le (N)-PDU est l'unité de données pour une couche (numéro N).
Bootstrap Protocol(BOOTP) est un protocole réseau d'amorçage, qui permet à une machine cliente sans disque dur de découvrir sa propre adresse IP, l'adresse d'un hôte serveur, et le nom d'un fichier à charger en mémoire pour exécution. On peut représenter l'amorçage comme une opération se produisant en deux phases : Détermination d'adresses et sélection du fichier de démarrage, c'est ici qu'intervient BOOTP. Transfert du fichier de démarrage, le transfert utilisera typiquement le protocole TFTP, ou encore .
AppleTalkest un protocole de communication d'Apple. Il est employé par les ordinateurs Macintosh depuis 1984, d'abord en tant que partie intégrante du réseau LocalTalk puis en tant que protocole autonome (couches 3 à 5), le plus souvent au sein de trames Ethernet, l'ensemble étant baptisé EtherTalk. Utilisé jusqu'à la version Mac OS X 10.5.x du système d'exploitation, il a disparu dans Mac OS X 10.6. Le protocole TCP/IP et la technologie Bonjour ont définitivement pris le relais. LocalTalk EtherType Catégorie:Protoc
Réseau privé virtuelthumb|upright=1.8|Principe d'un VPN simple En informatique, un réseau privé virtuel (RPV) ou réseau virtuel privé (RVP), plus communément abrégé en VPN (de l'virtual private network), est un système permettant de créer un lien direct entre des ordinateurs distants, qui isole leurs échanges du reste du trafic se déroulant sur des réseaux de télécommunication publics. On utilise notamment ce terme dans le télétravail, ainsi que dans le cadre de l'informatique en nuage.
Protocole sans étatEn informatique, un protocole sans état (en anglais stateless protocol) est un protocole de communication qui n'enregistre pas l'état d'une session de communication entre deux requêtes successives. La communication est formée de paires requête-réponse indépendantes et chaque paire requête-réponse est traitée comme une transaction indépendante, sans lien avec les requêtes précédentes ou suivantes. Autrement dit, un protocole sans état ne nécessite pas que le serveur conserve, au cours de la session de communication, l'état de chacun des partenaires.