Uniform Resource IdentifierUn URI, de l'anglais Uniform Resource Identifier, soit littéralement identifiant uniforme de ressource, est une courte chaîne de caractères identifiant une ressource sur un réseau (par exemple une ressource Web) physique ou abstraite, et dont la syntaxe respecte une norme d'Internet mise en place pour le World Wide Web (voir RFC 3986). La norme était précédemment connue sous le terme UDI. L'IETF l'a d'abord défini dans la RFC 2396 en se basant sur des propositions de Tim Berners-Lee (RFC 1630).
État du résultat globalL'état du résultat global dans la terminologie IFRS, également nommé état des résultats ou compte du résultat (abrégé CR), est un état financier synthétisant l'ensemble des charges et des produits d'une entreprise ou autre organisme ayant une activité marchande, pour une période donnée, appelée exercice comptable. Le compte de résultat est donc un document de synthèse, faisant partie des états financiers, et ayant pour fonction d'indiquer la performance de l'entreprise.
Programmation orientée objetLa programmation orientée objet (POO), ou programmation par objet, est un paradigme de programmation informatique. Elle consiste en la définition et l'interaction de briques logicielles appelées objets ; un objet représente un concept, une idée ou toute entité du monde physique, comme une voiture, une personne ou encore une page d'un livre. Il possède une structure interne et un comportement, et il sait interagir avec ses pairs.
Sigil (informatique)Un sigil est le premier caractère d'un identificateur en Perl. Il est non alphanumérique et dénote son type. Donc, Perl n'est pas seulement un langage dynamiquement typé, c'est aussi un langage statiquement typé, bien qu'avec peu de types statiques. $a # variable de type scalaire @a # variable de type tableau %a # variable de type hash &a # fonction L'interpolation de scalaire dans une chaîne est très utile. Cette sémantique est héritée des shell Unix.
Littéral (programmation)En informatique, un littéral est une notation pour représenter une valeur fixe. Presque tous les langages de programmation ont des notations pour les valeurs atomiques telles que les entiers, les nombres à virgule flottante et les chaînes de caractères, et généralement pour les booléens et les caractères ; certains ont également des notations pour les éléments de types énumérés et les valeurs composées telles que les tableaux, les enregistrements et les objets. Une fonction anonyme est un littéral pour le type de fonction.
Constante (programmation informatique)En programmation informatique, une constante est une valeur qui ne doit pas être modifiée par le programme lors de son exécution normale, c'est-à-dire que la valeur est constante . Lorsqu'elle est associée à un identifiant, une constante est dite "nommée", bien que les termes "constante" et "constante nommée" soient souvent utilisés de manière interchangeable. Cela contraste avec une variable, qui est un identificateur dont la valeur peut être modifiée pendant l'exécution normale, c'est-à-dire que la valeur est variable.
Extensible Markup LanguageLExtensible Markup Language, généralement appelé XML, « langage de balisage extensible » en français, est un métalangage informatique de balisage générique qui est un sous-ensemble du Standard Generalized Markup Language (SGML). Sa syntaxe est dite « extensible » car elle permet de définir différents langages avec pour chacun son vocabulaire et sa grammaire, comme XHTML, XSLT, RSS, SVG... Elle est reconnaissable par son usage des chevrons () encadrant les noms des balises.
Opérateur (informatique)En programmation informatique, un opérateur est une fonction spéciale dont l'identificateur s'écrit généralement avec des caractères non autorisés pour l'identificateur des fonctions ordinaires. Il s'agit souvent des équivalents aux opérateurs mathématiques pour un langage de programmation. Les opérateurs peuvent effectuer des opérations arithmétiques, booléennes ou agir sur des chaînes de caractères. Contrairement aux fonctions, les opérateurs fournissent souvent les opérations primitives du langage.
Comptes annuelsActuellement, en France, les comptes annuels rassemblent le bilan, le compte de résultat et l'annexe des comptes d'une entreprise, qui sont établis à la clôture de l'exercice, selon l'article 130-1 du plan comptable général. Les comptes annuels doivent être présentés selon des normes standardisées, afin d'assurer une comparabilité des comptes entre les personnes. Différentes méthodes de comptabilité sont possibles ; cependant le choix d'une méthode comptable doit être permanent, afin d'assurer la comparabilité des comptes d'une même entreprise dans le temps.
Type systemIn computer programming, a type system is a logical system comprising a set of rules that assigns a property called a type (for example, integer, floating point, string) to every "term" (a word, phrase, or other set of symbols). Usually the terms are various constructs of a computer program, such as variables, expressions, functions, or modules. A type system dictates the operations that can be performed on a term. For variables, the type system determines the allowed values of that term.
Statement of changes in equityA statement of changes in equity and similarly the statement of changes in owner's equity for a sole trader, statement of changes in partners' equity for a partnership, statement of changes in shareholders' equity for a company or statement of changes in taxpayers' equity for government financial statements is one of the four basic financial statements. The statement explains the changes in a company's share capital, accumulated reserves and retained earnings over the reporting period.