Ask any question about EPFL courses, lectures, exercises, research, news, etc. or try the example questions below.
DISCLAIMER: The Graph Chatbot is not programmed to provide explicit or categorical answers to your questions. Rather, it transforms your questions into API requests that are distributed across the various IT services officially administered by EPFL. Its purpose is solely to collect and recommend relevant references to content that you can explore to help you answer your questions.
The following tables compare general and technical information between a number of notable IRC client programs which have been discussed in independent, reliable prior published sources. Basic general information about the notableclients: creator/company, license, etc. Clients listed on a light purple background are no longer in active development. A brief overview of the release history. The operating systems on which the clients can run natively (without emulation). Unix and Unix-like operating systems: Unix (BSD): 386BSD, BSD/OS, FreeBSD, NetBSD, OpenBSD, SunOS, ULTRIX Unix (System V): AIX, A/UX, HP-UX, IRIX, SCO OpenServer, Solaris, UnixWare Unix-like: Linux, NeXTSTEP, OpenVMS, OSF/1, QNX, Tru64 UNIX What IRC related protocols and standards are supported by each client. The Direct Client-to-Client Protocol (DCC) has been the primary method of establishing connections directly between IRC clients for a long time now. Once established, DCC connections bypass the IRC network and servers, allowing for all sorts of data to be transferred between clients including files and direct chat sessions. This software is compliant natively; other software may be compliant with extensions. IRC SASL authentication primarily uses the same mechanisms as SASL in other protocols. Most commonly: PLAIN as defined by RFC 4616 EXTERNAL as defined by RFC 4422 SCRAM-SHA-256 as defined by RFC 7677 Information on what features each of the clients support.